re = /(?:(?<exitingN>N)|((?<exitingF>[UMTREL]{1})(?<exitingNumber>[0-9]+)))-((?<enteringB>B)|(?:(?<enteringF>[UMTREL]{1})(?<enteringNumber>[0-9]+)))/m
str = 'N-U0 U0-M1
M1-T9 T9-R10 R10-E19
E19-L100 L100-B'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end