package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*`)
var str = `300`
var substitution = "[add]$0]:"
fmt.Println(re.ReplaceAllString(str, substitution))
}