use strict;
my $str = '300';
my $regex = qr/^.*/p;
my $subst = '[add]$0]:';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";