import Foundation
let pattern = #"^.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"300"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[add]$0]:"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)