package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S*\d\S*`)
var str = `Перенос остатков денежных средств с л/с 05564П56000 на л/с 05564Ф56010 сложившихся по состоянию на 01.01.2023г. на основании письма от 27.12.2022г. №НП-03-24/32768`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}