import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S*\\d\\S*";
final String string = "Перенос остатков денежных средств с л/с 05564П56000 на л/с 05564Ф56010 сложившихся по состоянию на 01.01.2023г. на основании письма от 27.12.2022г. №НП-03-24/32768";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}