re = /\S*\d\S*/m
str = 'Перенос остатков денежных средств с л/с 05564П56000 на л/с 05564Ф56010 сложившихся по состоянию на 01.01.2023г. на основании письма от 27.12.2022г. №НП-03-24/32768'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end