#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<Timestamp>\w{3}\s+\d{1,2}\s\d{1,2}:\d{2}:\d{2})\s(?P<A1>\w+)\s(?P<A2>[\S]+)\:\s(?P<A3>.*)"
Local $sString = "Jan 9 01:04:49 syntax sshd(pam_unix)[21354]: authentication failure; logname= uid=0 euid=0 tty=NODEVssh ruser= rhost=120-123-141-4.hinet-ip.hinet.com " & @CRLF & _
"" & @CRLF & _
"Jul 10 04:17:11 syntax su(pam_unix)[95367]: session opened for user abc by (uid=0)" & @CRLF & _
"" & @CRLF & _
"May 1 14:06:19 syntax su(pam_unix)[95367]: session closed for user abc" & @CRLF & _
"" & @CRLF & _
"Oct 23 18:08:26 syntax logrotate: ALERT exited abnormally with [1]" & @CRLF & _
"" & @CRLF & _
"Jun 14 21:42:52 syntax su(pam_unix)[95367]: session opened for user cbx by (uid=0)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")