import re
regex = re.compile(r"(?P<Timestamp>\w{3}\s+\d{1,2}\s\d{1,2}:\d{2}:\d{2})\s(?P<A1>\w+)\s(?P<A2>[\S]+)\:\s(?P<A3>.*)", flags=re.MULTILINE)
test_str = ("Jan 9 01:04:49 syntax sshd(pam_unix)[21354]: authentication failure; logname= uid=0 euid=0 tty=NODEVssh ruser= rhost=120-123-141-4.hinet-ip.hinet.com \n\n"
"Jul 10 04:17:11 syntax su(pam_unix)[95367]: session opened for user abc by (uid=0)\n\n"
"May 1 14:06:19 syntax su(pam_unix)[95367]: session closed for user abc\n\n"
"Oct 23 18:08:26 syntax logrotate: ALERT exited abnormally with [1]\n\n"
"Jun 14 21:42:52 syntax su(pam_unix)[95367]: session opened for user cbx by (uid=0)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")