import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<Timestamp>\\w{3}\\s+\\d{1,2}\\s\\d{1,2}:\\d{2}:\\d{2})\\s(?P<A1>\\w+)\\s(?P<A2>[\\S]+)\\:\\s(?P<A3>.*)";
final String string = "Jan 9 01:04:49 syntax sshd(pam_unix)[21354]: authentication failure; logname= uid=0 euid=0 tty=NODEVssh ruser= rhost=120-123-141-4.hinet-ip.hinet.com \n\n"
+ "Jul 10 04:17:11 syntax su(pam_unix)[95367]: session opened for user abc by (uid=0)\n\n"
+ "May 1 14:06:19 syntax su(pam_unix)[95367]: session closed for user abc\n\n"
+ "Oct 23 18:08:26 syntax logrotate: ALERT exited abnormally with [1]\n\n"
+ "Jun 14 21:42:52 syntax su(pam_unix)[95367]: session opened for user cbx by (uid=0)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}