using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*-\s*";
string substitution = @" - ";
string input = @"BA-English
BA - English
BA - Chemistry
BS - Rubber Chickens";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}