$re = '/\s*-\s*/m';
$str = 'BA-English
BA - English
BA - Chemistry
BS - Rubber Chickens';
$subst = " - ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;