re = /\s*-\s*/m
str = 'BA-English
BA - English
BA - Chemistry
BS - Rubber Chickens'
subst = ' - '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result