using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:19|20)\d\d([-/.])(?:0?[1-9]|1[012])\1(?:0?[1-9]|[12][0-9]|3[01])|(?:0?[1-9]|[12][0-9]|3[01])([-/.])(?:0?[1-9]|1[012])\2(?:19|20)(?:\d\d)?)$";
string input = @"31-1-20
1-12-1990
1900/08/23
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}