$re = '`^(?:(?:19|20)\d\d([-/.])(?:0?[1-9]|1[012])\1(?:0?[1-9]|[12][0-9]|3[01])|(?:0?[1-9]|[12][0-9]|3[01])([-/.])(?:0?[1-9]|1[012])\2(?:19|20)(?:\d\d)?)$`m';
$str = '31-1-20
1-12-1990
1900/08/23
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);