package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((0[1-9]|[12]\d|3[01]])-(0[1-9]|1[0-2])-[12]\d{3}(?:\s[mf])?)`)
var str = `: 02-03-1980 m or 02-03-1980 f but`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}