const regex = /((0[1-9]|[12]\d|3[01]])-(0[1-9]|1[0-2])-[12]\d{3}(?:\s[mf])?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((0[1-9]|[12]\\d|3[01]])-(0[1-9]|1[0-2])-[12]\\d{3}(?:\\s[mf])?)', 'gm')
const str = `: 02-03-1980 m or 02-03-1980 f but`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}