re = /((0[1-9]|[12]\d|3[01]])-(0[1-9]|1[0-2])-[12]\d{3}(?:\s[mf])?)/m
str = ': 02-03-1980 m or 02-03-1980 f but'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end