package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*([a-zA-Z]).*\s+([a-zA-Z])\S+$`)
var str = `A A BCD EFG`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}