$re = '/^\s*([a-zA-Z]).*\s+([a-zA-Z])\S+$/m';
$str = 'A A BCD EFG';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;