use strict;
my $str = 'A A BCD EFG';
my $regex = qr/^\s*([a-zA-Z]).*\s+([a-zA-Z])\S+$/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";