using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{2}(\/|-)\d{2}(\/|-)(\d{2}|\d{4})|(\d{2}|\d{4})(\/|-)\d{2}(\/|-)\d{2})$";
string input = @"1989/05/20";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}