re = /^(\d{2}(\/|-)\d{2}(\/|-)(\d{2}|\d{4})|(\d{2}|\d{4})(\/|-)\d{2}(\/|-)\d{2})$/m
str = '1989/05/20'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end