package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{2}(\/|-)\d{2}(\/|-)(\d{2}|\d{4})|(\d{2}|\d{4})(\/|-)\d{2}(\/|-)\d{2})$`)
var str = `1989/05/20`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}