# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*Updated://s;t' <<< "Blah blah
blah, Updated: Aug. 23, 2012 Blah blah Updated: Feb. 13, 2019"