using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*Updated:";
string substitution = @"";
string input = @"Blah blah
blah, Updated: Aug. 23, 2012 Blah blah Updated: Feb. 13, 2019";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}