#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)^.*Updated:"
Local $sString = "Blah blah" & @CRLF & _
"blah, Updated: Aug. 23, 2012 Blah blah Updated: Feb. 13, 2019"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)