import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^\\d{1,2}\\/\\d{1,2}\\/\\d{4})";
final String string = "18/07/2018, 18:04 - Person2: message\n"
+ "18/07/2018, 18:04 - Person1: Yes\n"
+ "18/07/2018, 18:04 - Person2: That's good then\n"
+ "18/07/2018, 18:05 - Person1: message line 1\n"
+ " message line 2\n"
+ "18/07/2018, 18:05 - Person2: text\n"
+ "18/07/2018, 18:05 - Person2: But nvm\n"
+ "18/07/2018, 18:06 - Person1: text";
final String subst = "-------------\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}