use strict;
my $str = '18/07/2018, 18:04 - Person2: message
18/07/2018, 18:04 - Person1: Yes
18/07/2018, 18:04 - Person2: That\'s good then
18/07/2018, 18:05 - Person1: message line 1
message line 2
18/07/2018, 18:05 - Person2: text
18/07/2018, 18:05 - Person2: But nvm
18/07/2018, 18:06 - Person1: text';
my $regex = qr/(?=^\d{1,2}\/\d{1,2}\/\d{4})/mp;
my $subst = '-------------\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";