import re
regex = re.compile(r"(?=^\d{1,2}\/\d{1,2}\/\d{4})", flags=re.MULTILINE)
test_str = ("18/07/2018, 18:04 - Person2: message\n"
"18/07/2018, 18:04 - Person1: Yes\n"
"18/07/2018, 18:04 - Person2: That's good then\n"
"18/07/2018, 18:05 - Person1: message line 1\n"
" message line 2\n"
"18/07/2018, 18:05 - Person2: text\n"
"18/07/2018, 18:05 - Person2: But nvm\n"
"18/07/2018, 18:06 - Person1: text")
subst = "-------------\\n"
result = regex.sub(subst, test_str)
if result:
print(result)