using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^href]*+href=(?:'|"")melt:\/\/";
string input = @"<a data=""some"" href=""melt://navigatetoitem/RHEU-1218304-0000_html_0002.html"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}