$re = '/<a[^href]*+href=(?:\'|")melt:\/\//m';
$str = '<a data="some" href="melt://navigatetoitem/RHEU-1218304-0000_html_0002.html">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);