// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a[^href]*+href=(?:'|")melt:\/\/"#).unwrap();
let string = "<a data=\"some\" href=\"melt://navigatetoitem/RHEU-1218304-0000_html_0002.html\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}