using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""(?i)(?<Type>availableBalance)"")\s*:\s*""?(?<Value>[^\n""]*)""?";
string input = @"{
""availableBalance"": ""Super hero squad"",
""homeTown"": ""Metro City"",
""availableBalance"": 2016,
""secretBase"": ""Super tower"",
""active"": true
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}