// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)("(?i)(?<Type>availableBalance)")\s*:\s*"?(?<Value>[^\n"]*)"?"#).unwrap();
let string = "{
\"availableBalance\": \"Super hero squad\",
\"homeTown\": \"Metro City\",
\"availableBalance\": 2016,
\"secretBase\": \"Super tower\",
\"active\": true
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}