import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"(?i)(?<Type>availableBalance)\")\\s*:\\s*\"?(?<Value>[^\\n\"]*)\"?";
final String string = "{\n"
+ " \"availableBalance\": \"Super hero squad\",\n"
+ " \"homeTown\": \"Metro City\",\n"
+ " \"availableBalance\": 2016,\n"
+ " \"secretBase\": \"Super tower\",\n"
+ " \"active\": true\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}