package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<myField1>[^\s:]+):*(?<myField2>\S*)`)
var str = `fieldValue1
fieldValue1:fieldValue2
fieldValue1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}