$re = '/(?<myField1>[^\s:]+):*(?<myField2>\S*)/';
$str = 'fieldValue1
fieldValue1:fieldValue2
fieldValue1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);