re = /(?<myField1>[^\s:]+):*(?<myField2>\S*)/
str = 'fieldValue1
fieldValue1:fieldValue2
fieldValue1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end