import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:Bundle\\s+Components|Included\\s+Components)\\s+.*?(?=Bundle)";
final String string = " Included Components\n"
+ " blah blah, like above,\n"
+ " Bundle Type\n\n"
+ "Bundle Components bla blah\\blabla?!()\\\\ANY CHARACTER IS POSSIBLE HERE, EVEN LINEBREAK,blah blah\n"
+ "Bundle Type";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}