$re = '/(?:Bundle\s+Components|Included\s+Components)\s+.*?(?=Bundle)/s';
$str = ' Included Components
blah blah, like above,
Bundle Type
Bundle Components bla blah\\blabla?!()\\\\ANY CHARACTER IS POSSIBLE HERE, EVEN LINEBREAK,blah blah
Bundle Type';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);