re = /(?:Bundle\s+Components|Included\s+Components)\s+.*?(?=Bundle)/
str = ' Included Components
blah blah, like above,
Bundle Type
Bundle Components bla blah\\blabla?!()\\\\ANY CHARACTER IS POSSIBLE HERE, EVEN LINEBREAK,blah blah
Bundle Type'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end