using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=/)[^/]+(?=/)";
string input = @"А как убрать пустые поля при написании в таком ввиде /lol/kuh/regeditom/pendol///";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}