$re = '@(?<=/)[^/]+(?=/)@';
$str = 'А как убрать пустые поля при написании в таком ввиде /lol/kuh/regeditom/pendol///';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);