re = /(?<=\/)[^\/]+(?=\/)/
str = 'А как убрать пустые поля при написании в таком ввиде /lol/kuh/regeditom/pendol///'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end