$re = '/SYS\.DBMS_SCHEDULER\.RUN_JOB\([\'\"](.*?)[\'\"]\)\;/';
$str = 'SYS.DBMS_SCHEDULER.RUN_JOB(\'CALCULO_AGIL_DT_POSTO");
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);