re = /SYS\.DBMS_SCHEDULER\.RUN_JOB\([\'\"](.*?)[\'\"]\)\;/
str = 'SYS.DBMS_SCHEDULER.RUN_JOB(\'CALCULO_AGIL_DT_POSTO");
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end