import re
regex = re.compile(r"^\s*(\w{2,})\s*(\w{2,})\w*|\s*$", flags=re.MULTILINE)
test_str = ("Mark Full\n"
" Mark Full \n"
" Mark Full dsad\n"
" Mark\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")