re = /^\s*(\w{2,})\s*(\w{2,})\w*|\s*$/m
str = 'Mark Full
Mark Full
Mark Full dsad
Mark
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end