package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.[^«]*«[^»]*»`)
var str = `Text1.
Textt « text2 »
Some other text`
var substitution = "."
fmt.Println(re.ReplaceAllString(str, substitution))
}